Display casting

I tried this today, but was not able to get this to work. VLC on the PC span for 10 seconds trying to connect then aborted. Are there any additional changes, like firewall, that need to be made to the PC? Ta.

You have to ensure that your phone can see and access the pc in your network (e.g. try to ping your PC’s IP). And of course you need to open the UDP port you used for streaming in your firewall (in my example the UDP port 12345)

I tried your steps but I also was not able to get this to work as @mgrayson. I turned off the firewall. I checked my glasses and PC are on the same network and the ping works between them (when the fireall is off). I changed the VideoCapture2LocalExample.cs like this:

I still didn’t get this to work - was hoping to try again very soon, but do let me know if you have any success @matsu

Isn’t this in the docs also a possibility?
First Person Stream

I don’t found the files but maybe someone else can help with this ?

1 Like

Thank you for the link. I will try it later.

I am also interested in this, anyone have the files?

If i try this, i get the error "Could not open output file ‘rtp://192.168.1.16:12345’ ", on the glasses, did you used the m_VideoCapture.StartRecordingAsync() method for this ?

I tried this today,but i got an error with “live555 error: no data received in 10s, aborting” when I open the SDP file

It worked! I used a port 8080 and could see the image on VLC player.

1 Like

you could also use GStreamer:

gst-launch-1.0 -v udpsrc port=12345 caps = "application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, payload=(int)96" ! rtph264depay ! decodebin ! videoconvert ! autovideosink

It worked for me on port 8080 (didn’t try port 12345), but I have a delay of around 2 seconds.
Is there a way to speed this up?

I am facing the same. 1 - 2 secons of delay…

I also have a seceral seconds delay.

FYI:

I could not do the streaming cast with “.NET Standard 2.0” of Api Compatibility Configuration setting in the Player settings while I could do it with “.NET 4.x”.

Feedbacks:

  • I sometimes get a freeze when starting/stopping the casting with the buttons.
  • I have not received audio with this way even if the useAudio checkbox is on. I have added a line of <uses-permission android:name="android.permission.RECORD_AUDIO" /> to the AndroidManifest.xml and it’s set as on in the app setting page on a phone device. If you can, I would like to know how to send audio by this way.

Did you manage with FPSCasting or the tutorial above? I can’t seem to get it working…

Yes. It should work. Do you turn off your fire wall? Your glasses and PC are in the same network?

Hopefully this recent thread could help: First Person View recording/streaming with NRSDK1.7.0 - NRSDK - Nreal Community Forum

1 Like

Is it normal that the quality of the streaming is better on a mac compared to a windows pc? (Despite them having similar specs)