Nebula app doesn't work on M2 MB Pro

Hi,

I’ve purchased Nreal light strictly for the purpose of working with virtual screens. However, the Nebula app crashes every time I click Start AR Desktop. It loads for a while and then asks me to restart the app and reconnect glasses. I’ve tried multiple settings of monitors but there’s little configuration options I can try.

The glasses work fine in mirror or extended monitor mode, without the Nebula app.

I’m using Nebula for Mac version 0.2.0_931 on MacOS 13.1 with M2 MB Pro. The only non-standard thing of this setup is 24GB RAM.

If that might be important - I don’t have a phone compatible with the glasses as I only planned to use them with the computer.

Hi, please confirm if you have ever installed the old version of Mac Nebula on your Mac, if yes, maybe you need to uninstall the old one totally. If no, then please check all the permissions are allowed for Nebula, and reboot your Mac.

Hi, I’m experiencing the same exact issues with the Nreal Light, I got them new today and I’ve downloaded the mac app directly from the site, all permissions are active and I’ve rebooted a few times. The issue is only with the Lights, I borrowed a friend’s Airs and they work correctly.

This is on an M1 Mac OS Version Monterey 12.5 Build 21G72

I do not have an android phone

Please disable the permissions first, then exit the app. After that, allow the permissions again and open the app.

Yup I’ve just tried that and there was no change, still nothing.

It’s nothing I hadn’t tried before opening the thread here.

I noticed that you have already discussed this issue with our colleague on Reddit. And we are analyzing the issue now. Please give us some more time. By the way, please confirm if your Light is the red one?