Nebula App for Mac Update

So there was a previous thread on this but seemingly was before the update and might have been a HDMI compatibility issue. I updated the nebula app today and it tried to update glasses. Update failed. Redownloaded firmware and nebula app and updated MCU and DP using chrome. Reddit post to that has not been answered. App seems to recognize the glasses but when trying to launch multi screen AR continually says “Reconnect Glasses and Reopen App” Using M1 Pro MBP Ventura 13.3

1 Like

Hi, could you please confirm if you connect the glass to your Mac directly, instead of using a hub? Also, please try to delete all the relating files of the old version of Mac Nebula and reinstall the V0.2.1. By the way, I wondered if you used Light on your Mac?

Yes, it is connected directly to the Mac without any adapter or connector. I have deleted all associated files gone through the updating of MCU process again, and I am using the nreal air. Multiple users on Reddit reporting same issue.

Diving more into testing I found that the new release works flawlessly on Mac Ventura 13.1. But im using 13.3 and another user using 13.2 is having issues. Could this be that the new beta release only works on 13.1 and below? So OS 12.0 to 13.1? That being said the new update is very cool, much needed functionalities.

Thanks for your feedback, we will try to do more tests on V13.2 and V13.3.

1 Like

Please post any updates.

As once on new version of Mac OS especially beta almost impossible to revert to previous iterations.

I also have this problem, on several Macs. I’ve tried downgrading to the old version of Nebula as well, without success. I’ve also updated it/tried it through an Android phone, but no change.

Could you please tell me if you also used the Air glass and connect it to your Mac directly without any hub?

Yes, it’s connected directly without hubs etc.

…and I just tested that Nebula worked great (nice changes!) in macOS 13.2, but as soon as I upgraded the same computer to 13.3 it stopped working.

on 5 Mac devices 13.2 works until upgrading the MCU and DP. in testing the App update worked then didnt work at all when firmware was updated using Chrome. And doesn’t work at all on 13.3

Do you know if we should expect an update that would make 13.3 work anytime soon? Or would it be when 13.3 has a public release? Or is there any issue with 13.3 that is preventing it. Just wondering if I should be patient or return computer to factory settings.

Hi, we are trying to find other ways to realize a stable multi-screen experience. So there may not be a public release of Mac Nebula recently.