Nebula update doesn't like my version of the glasses, but the previous version did

I just updated to the latest Nebula version 2.01.00 and the installation went well. When I plug in my glasses however, I get this message: “This is one older version of the glasses, please us the commercialized version”. Has anyone else run into this problem? The previous version of Nebula worked well with my glasses.

There’s an option in Nebula to auto check and update the glasses firmware. Try it maybe that’s what is missing.

What glasses are you using by the way? Devkit or commercial? From which country?

I’m using the Devkit glasses I obtained in February 2020. The firmware version in the glasses is: 03.1.04.008_20201026_0024. Thanks for the suggestion about the auto check option in Nebula - where is this option? I don’t see it in latest Nebula release.

It’s in the development options in Nebula.

First go to the about page, and click on the Nreal 10 logo 10 times tell you get a message that development mode is on.

Now leave the about page and go to Settings. You’ll see a new button at the bottom to access the development options.

Thanks Mr.FarePlay. The Auto Update Glasses Firmware is already set to On. And still getting the “… older version of glasses…” message. I wonder why my glasses worked fine with the previous version of Nebula !?

Btw, in the Developer Options, there’s a save button - so you know what the MR package name is that should be entered here when you want to save any configurations updates?

Hi there, devkit glasses that are any color other than black are actually an older version of the Nreal Light hardware and that’s why you get that message. You should be able to just accept the message on the screen and continue on and be able to use Nebula. I think they put that message there as some functionality may turn out to be different on older devkit hardware than on the commercial product. As an example, my old devkit wouldn’t allow connection to a PC via USB-C but my consumer version does.

The option to launch an MR Package Name is if you want Nebula to automatically launch your app instead of the Nebula menu. You’d have to specify your package name and that’s likely only useful if you have an installation or something where you want to restrict usage to a specific application.

Hope this helps!

HI eminus - I was able to accept the message and continue with the previous version of Nebula, but now with the version 2.01.00, I can launch Air Casting, but when launching MR Space, it displays a ‘Plug in your glasses to enter Nebula’ message at the bottom of the Nebula launch page (the glasses are plugged in). And subsequently when I tap on the MR Space button I get a ‘Failed to switch mode’ message. Alas, it seems like the Nebula just doesn’t like the old glasses…

Thanks for your suggestions and help.

Just a quick update - I uninstalled the latest version of Nebula (v2.01.00…) and reinstalled the previous version (v2.00.00.151) and MR Space is working again as before with my original Red Nreal glasses. I hope Nreal continues to support these Red glasses and provides instructions on how to configure present and future versions of Nebula to work with them (at least for a while longer), I think it would be in their best interest as well as in the best interest of the developer community.

1 Like