Trouble initializing RGB camera (SOLVED: Nebula was power saving mode)

Hey, I’m having issues accessing the RGB camera with the newest version of the preview SDK. I’ve followed the guide and tried running it on multiple NReal Light glasses and phones, so it doesn’t seem to be a hardware issues. Could anyone point me in the right direction?

The nrsensor logs read:

[INFO] [NRSensor] RGB Camera got false handle, work type = 0
[INFO] [NRSensor] RGB Camera protocol 0 MATCHED
[INFO] [NRSensor] RGB Camera protocol load SUCCESS
[INFO] [NRSensor] RGB Camera initialized
[INFO] [NRSensor] RGB Camera starting
[FATAL] [NRSensor] Generic Camera find device : No such device (-4)
[ERROR] [NRSensor] Generic Camera start failed

Just to cover all points. Have you disabled power saving mode in Nebula’s settings?

Which version of the NRSDK and Nebula are you using?

2 Likes

It was indeed the power saving mode… I must have missed that setting somehow, sorry for the stupid question.

1 Like

Not at all. Glad to help :+1: